Author Topic: Reconnect Issue - Win32  (Read 3714 times)

Doggan

  • User
  • *
  • Posts: 1
Reconnect Issue - Win32
« on: June 14, 2006, 11:37:35 AM »
I'm wondering if you have ever run into this issue on Win32. It seems there is a bug somewhere. When a client disconnects from the server, this randomly blocks this same client and any other client from ever connecting to the server again. The server is forced to shut down and restart. As soon as the server shuts down, all clients become unblocked and will produce a connection failure. Is this possibly a threading bug?

Sometimes a client is able to connected and disconnect multiple times, but usually the first disconnect triggers this behavior.

Program flow gets stuck on line 253 of Thread.cpp (GNE version .70):

valassert(WaitForSingleObject( id->hThread, INFINITE ), WAIT_OBJECT_0);

The calling sequence is: GNE::ClientConnection::waitForConnect -> GNE::Thread::join

This is GNE .70, compiled w/ HawkNL 1.68 (and 1.66... I've tried both) and Boost 1.33.1 on Windows XP w/ VC++ 2003. I've tried the latest CVS, but this seemed to be creating other problems ;)

I realize you are no longer very active on this project, but I'm just curious if you ever ran into this before. Thanks.

Gillius

  • Administrator
  • User
  • *****
  • Posts: 147
    • http://www.gillius.org/
Reconnect Issue - Win32
« Reply #1 on: June 15, 2006, 08:28:11 AM »
The issue sounded familiar at first, but I don't think I have seen this before.  Someone reported a problem with reconnecting and trying to set setGameInformation again, and that bug was fixed in CVS.

I would be somewhat interested to hear what problems you were having with the CVS version because it contains mostly bug fixes (and some substantial ones too) -- see the CHANGES file.  Based on what I remember, I haven't changed any APIs and haven't made any changes likely to introduce new bugs.
Gillius
Gillius's Programming http://www.gillius.org/